When attempting to run local dev environ, getting Mongrel missing error
  • I'm attempting to run vae from the command line for the local dev environment in Ubuntu 12.04. I have ruby 1.8 install and have install mongrel 1.1.5. However when I run vae, I get the following error:

    /usr/local/vae/vae_local/lib/vae.rb:3:in `require': no such file to load -- mongrel (LoadError)
    from /usr/local/vae/vae_local/lib/vae.rb:3
    from /usr/local/bin/vae:7:in `require'
    from /usr/local/bin/vae:7

    The output of gem list --local is this:

    cgi_multipart_eof_fix (2.5.0)
    daemons (1.1.8, 1.0.10)
    fastthread (1.0.7)
    gem_plugin (0.2.3)
    mongrel (1.1.5)

    Why is vae unable to find mongrel?

  • 4 Answers sorted by
  • Most likely explanation is that Vae is using the wrong Ruby. Do you have RVM or Rbenv installed?

  • I don't have RVM or Rbenv installed as far as I know. I only have one version of ruby installed also (1.8). I also tried using 1.9 with mongrel 2, but I got the same error.

  • I'd encourage you to take this over to support so we can try some more back-and-forths. Just email [email protected]

  • Vae needs Ruby v1.8.7 to run, it is not forward compatible yet.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

In this Discussion