General http://forum.vaeplatform.com/categories/general/feed.rss Thu, 01 Nov 12 02:45:02 -0400 General en-CA Problem uploading (largish) video file http://forum.vaeplatform.com/discussion/314/problem-uploading-largish-video-file Mon, 15 Oct 2012 13:37:45 -0400 sebbean 314@/discussions
I've setup a new collection and added a field for a video file.

I've been attempting to get the highest possible video quality settings for the file while also being highly compressed.

We've essentially got a 1920x1920 h.264 video file with ~60% quality setting - we end up with a ~10-20 mb file that contains a 30s loop of a 'product'.

The issue we're having is that vae doesn't seem to like the file when we attempt to upload it. At slightly lower compressions we were

Here's the file:

http://staging.ginlanemedia.com/blue_backpack.mov
http://staging.ginlanemedia.com/blue_backpack.mov.zip (if you're trying to download instead of view).


We've found a workaround which is basically to upload to a 'file' type of field instead of a 'video'. However we were wanting to utilize some of your video resizing features down the line and we were hoping you could help us figure out this issue.


-sb
]]>
Google analytics - Ecommerce Tracking http://forum.vaeplatform.com/discussion/313/google-analytics-ecommerce-tracking Wed, 26 Sep 2012 19:21:04 -0400 michael 313@/discussions https://developers.google.com/analytics/devguides/collection/gajs/gaTrackingEcommerce

However, is that info retrievable on the 'Thank You' page in Vae? I will test this, however my gut says no.

Developers, how have you added Ecommerce Tracking to Vae in the past?


]]>
Using Amazon Cloudfront to reduce your bandwidth bill or speed up your site http://forum.vaeplatform.com/discussion/305/using-amazon-cloudfront-to-reduce-your-bandwidth-bill-or-speed-up-your-site Thu, 26 Jul 2012 23:51:26 -0400 Kevin 305@/discussions
Amazon Cloudfront is a global CDN (Content delivery network) that caches copies of your assets at various global locations.

They also charge less than we do for data transfer.

It's pretty easy to set up, so here's how to do it:

1. The first thing you will want to do is setup an Amazon Web Services account, which can be done, for free, here:

http://aws.amazon.com/

2. Sign in to the console: https://console.aws.amazon.com/s3/home

3. Click the Amazon CloudFront tab.
4. Click the Create Distribution button.
5. Select Other… from the Origin drop down.
6. In the Bucket Name field, enter .vaesite.net. Make SURE you replace with your Vae subdomain, and be sure that you enter .net, not .com.
7. Make sure Distribution Status is set to Enabled.
8. Click the Create button, and you are done.

Amazon will give you a "distribution URL". Send this email to us at support@actionverb.com and we'll activate it for your account. Then we'll use Cloudfront for all your site's asset serving.]]>
Using domain name to pull/filter content from a specific entry in a root-level collection http://forum.vaeplatform.com/discussion/291/using-domain-name-to-pullfilter-content-from-a-specific-entry-in-a-root-level-collection Fri, 27 Apr 2012 06:24:55 -0400 seb 291@/discussions
Perhaps there is a way of setting some kind of session that will set the "domain-variable"?

<v:collection path="/rootlevel[url='mydomain.com']">]]>
When attempting to run local dev environ, getting Mongrel missing error http://forum.vaeplatform.com/discussion/292/when-attempting-to-run-local-dev-environ-getting-mongrel-missing-error Mon, 07 May 2012 18:00:36 -0400 gregg 292@/discussions
/usr/local/vae/vae_local/lib/vae.rb:3:in `require': no such file to load -- mongrel (LoadError)
from /usr/local/vae/vae_local/lib/vae.rb:3
from /usr/local/bin/vae:7:in `require'
from /usr/local/bin/vae:7

The output of gem list --local is this:

cgi_multipart_eof_fix (2.5.0)
daemons (1.1.8, 1.0.10)
fastthread (1.0.7)
gem_plugin (0.2.3)
mongrel (1.1.5)

Why is vae unable to find mongrel?]]>
Error when invoking vae http://forum.vaeplatform.com/discussion/293/error-when-invoking-vae Tue, 08 May 2012 09:18:25 -0400 gregg 293@/discussions
/usr/local/vae/vae_local/lib/vae.rb:91:in `run!': undefined method `[]' for false:FalseClass (NoMethodError)
from /usr/local/vae/vae_local/lib/vae.rb:87:in `each'
from /usr/local/vae/vae_local/lib/vae.rb:87:in `run!'
from /usr/local/vae/vae_local/lib/vae.rb:168:in `run_trapping_exceptions!'
from /usr/local/bin/vae:9

What is the cause of this? I'm new to ruby so it is difficult for me to debug.]]>
Password-Protect Staging Site http://forum.vaeplatform.com/discussion/288/password-protect-staging-site Fri, 13 Apr 2012 10:46:24 -0400 Scott 288@/discussions
I think using an .htaccess to white-list the production domain(s) would be the best route for Vae, but that leads to a question or two:

Can we use .htpasswd files with Vae?
If so, what is the server path to the .htpasswd file if we put it in the root FTP directory?

Thanks.]]>
running SCSS with Vae local preview server, version 0.5.0 http://forum.vaeplatform.com/discussion/284/running-scss-with-vae-local-preview-server-version-0.5.0 Mon, 02 Apr 2012 12:00:25 -0400 michael 284@/discussions
-use the 'sass watch' command and just link the generated css file?


I have linked the file via
%v:asset{:src => "/css/style.scss"}

It does not work locally, but works fine when on staging.]]>
Clean URLs http://forum.vaeplatform.com/discussion/75/clean-urls Thu, 20 Jan 2011 14:20:01 -0500 michael 75@/discussions
I know I could do
website.com/exhibitions.php?grouping=current

But is there a way to use cleaner URLs for the three main landing pages:
website.com/exhibitions/current
website.com/exhibitions/upcoming
website.com/exhibitions/press

It would pull from the Exhibitions structure.

I cannot use permalinks because I am using them for when you are at a single Exhibition:

website.com/exhibitions/exhibition-title
]]>
DNS requirements for hosting http://forum.vaeplatform.com/discussion/283/dns-requirements-for-hosting Fri, 30 Mar 2012 16:30:32 -0400 rama 283@/discussions Segmentation fault: 11 http://forum.vaeplatform.com/discussion/277/segmentation-fault-11 Wed, 08 Feb 2012 02:48:19 -0500 Breefield 277@/discussions http://localhost:9999 and in the terminal I see Segmentation fault: 11 and the process terminates.

File won't upload, so here's a link.
http://cl.ly/1c0C3B390x0Y2F2S1g1z]]>
After import/export new website, 404 URL NOT FOUND http://forum.vaeplatform.com/discussion/278/after-importexport-new-website-404-url-not-found Wed, 08 Feb 2012 12:34:07 -0500 007007 278@/discussions
from my private space, I exported the site structure to my new account (new website), and I transferred all FTP files

my old site http://kimovitz.vaesite.com/
my new site http://kimovitz2.vaesite.com/

when I want to access my pages, I get an error:

http://kimovitz2.vaesite.com/collections

------------
The URL you requested does not exist on this website!

If you are the website owner, you should update your links to point to the correct location.

If you are not the website owner, your best bet is to contact the website owner and notify them of the problem.
------------

while it works well in the first version of the site

http://kimovitz.vaesite.com/collections

What is the problem? I missed something?

Thank you for your help ^^]]>
Importing changes to an entry with a child colleciton. http://forum.vaeplatform.com/discussion/140/importing-changes-to-an-entry-with-a-child-colleciton. Tue, 09 Aug 2011 22:50:28 -0400 adam_crvn 140@/discussions

<shop_items>
<inventory_number match="true">AB/988_CLONG01</inventory_number>
<image_gallery permalink="" id="618672">
<image>http://gagosian.vaeplatform.com/data/c4c9120408726e06e8ea2165c3b5ef8a8f76f71f.jpg</image>
<caption>""</caption>
</image_gallery>
<image_gallery permalink="" id="618673">
<image>http://gagosian.vaeplatform.com/data/3c11a0180ab25f87a4e3fdc5084a9f3525c0d79f.jpg</image>
<caption>""</caption>
</image_gallery>
</shop_items>


Please note that I've additionally attempted to set image_gallery and image as match columns, and different combinations of the above, to no avail. The ultimate goal is to update the caption fields. I could actually easily repair the captions problem in a text editor with find and replace, but everytime I attempt to export the collection from Vae I get the white screen timeout again :(
]]>
Using Custom Ajax Scripts with Vae Forms http://forum.vaeplatform.com/discussion/165/using-custom-ajax-scripts-with-vae-forms Mon, 21 Nov 2011 15:11:18 -0500 Scott 165@/discussions
I am wondering if writing a custom ajax request using jQuery would provide a bit more control over the logic for errors, success, etc.]]>
Content Tab - Search Options? http://forum.vaeplatform.com/discussion/155/content-tab-search-options Tue, 20 Sep 2011 22:19:05 -0400 adam_crvn 155@/discussions Vae Local Development Environment Update: Includes Sass 3 http://forum.vaeplatform.com/discussion/144/vae-local-development-environment-update-includes-sass-3 Mon, 22 Aug 2011 17:19:24 -0400 Kevin 144@/discussions
You can download it at:
http://docs.vaeplatform.com/vae_local]]>
Update cart button not working... http://forum.vaeplatform.com/discussion/152/update-cart-button-not-working... Fri, 02 Sep 2011 17:43:09 -0400 thibodeaux 152@/discussions
< v:store:cart:items>

< v:checkbox path="remove" />
< v:img path="images/image" image_size="thumbnail" />
< v:text path="title" /> Callet
< v:text path="color/title" />
< v:text_field path="qty" size="1" />
$< v:text path="price" number_format="2" />
$< v:text path="total" number_format="2" />



< input type="submit" value="Update Cart" id="button2" />
</ v:store:cart:items>

Any ideas?]]>
Bug serving @font-face to IE in Vae Local EVN http://forum.vaeplatform.com/discussion/130/bug-serving-font-face-to-ie-in-vae-local-evn Sun, 10 Jul 2011 10:37:25 -0400 arron 130@/discussions
I run into a bug when using the recommended @font-face syntax in my css.

http://www.fontspring.com/blog/the-new-bulletproof-font-face-syntax

@font
-face {
font-family: 'MyFontFamily';
src: url('myfont-webfont.eot?#iefix') format('embedded-opentype'),
url('myfont-webfont.woff') format('woff'),
url('myfont-webfont.ttf') format('truetype'),
url('myfont-webfont.svg#svgFontName') format('svg');
}

If you look at the 3rd line with the url of "myfont-webfont.eot?#iefix"

In vae_site_servlet.rb (line 131) there is a statement that checks if the file is local or not. Well that '?' is in the path thats checked so it fails.

I just dropped this in right above that line.

local_path.sub!(/eot\??$/, 'eot')

It just checks that the file path ends in eot and if there is a trailing '?' it strips it out in place.

Hope that helps you out.

I was also thinking since the source is already accessible maybe you could think about putting it up on Github so patches could be submitted easier.

Also please let me know if there better way to submit kind of stuff.

Thanks

Arron]]>
Any vae-proficient developers looking for work? http://forum.vaeplatform.com/discussion/139/any-vae-proficient-developers-looking-for-work Sat, 30 Jul 2011 10:41:48 -0400 adam_crvn 139@/discussions Typekit inactive on vae staging site http://forum.vaeplatform.com/discussion/135/typekit-inactive-on-vae-staging-site Fri, 22 Jul 2011 16:57:10 -0400 Gordon 135@/discussions
I've been using typekit locally without any problems but when I go to push to the vae staging site, typekit goes into it's "inactive" state.
It seems to be working perfectly fine on the old verb staging site. take a look;

http://lola.verbsite.com/photos
https://lola.vaesite.com/photos

Any ideas on why this might be taking place?

-Gordon]]>
SVN with Wordpress http://forum.vaeplatform.com/discussion/138/svn-with-wordpress Wed, 27 Jul 2011 12:16:12 -0400 dmitry 138@/discussions
There are tons of other cases where a site need access to the filesystem for one reason or another, and source control is essential. Seems like a standard hosting feature. Is this a limitation or am I missing something?

]]>
Multi Association Order of Items http://forum.vaeplatform.com/discussion/134/multi-association-order-of-items Thu, 21 Jul 2011 14:05:28 -0400 dmitry 134@/discussions
Let's say I have a "related items" association to the "items" collection to which the item in question belongs. The collection is ordered manually, but this association is always alphabetical.

This presents a problem when outputting the related items because they are basically in random order. Is there any way to control this?]]>
Blog archive page. http://forum.vaeplatform.com/discussion/133/blog-archive-page. Mon, 18 Jul 2011 10:55:15 -0400 arron 133@/discussions
I'm about to start building out the blog section of a site and I'm trying to think through what's the best way to build out the archive pages based off the blog posts date. Do you guys have any ideas or examples of how it's been done before. I know I can roll my own but I figured I would ask here first.

Thanks,

Arron Mabrey]]>
A general thank you to the Vae Team http://forum.vaeplatform.com/discussion/49/a-general-thank-you-to-the-vae-team Fri, 12 Nov 2010 22:01:41 -0500 greg 49@/discussions
We love you!

Greg]]>
Gzip and Vae http://forum.vaeplatform.com/discussion/121/gzip-and-vae Wed, 15 Jun 2011 21:56:27 -0400 Scott 121@/discussions __vae.yml syntax http://forum.vaeplatform.com/discussion/124/__vae.yml-syntax- Sun, 26 Jun 2011 11:02:53 -0400 arron 124@/discussions
http://docs.vaeplatform.com/vae_local]]>
Importing HTML content http://forum.vaeplatform.com/discussion/125/importing-html-content Mon, 27 Jun 2011 22:09:23 -0400 adam_crvn 125@/discussions
What is the proper format for importing HTML via XML into Vae?]]>
Bulk image uploading http://forum.vaeplatform.com/discussion/123/bulk-image-uploading Wed, 22 Jun 2011 18:15:40 -0400 adam_crvn 123@/discussions
In the current sql db there is a table specifically for files, consisting of IDs and relative URLs. This wouldn't make sense for Vae, so we're writing a script to refactor the data for an import to Vae. But I don't know what to do about all these images. We can import the entire site, but then do we have to manually upload each image? If we imported an XML file with, say, absolute links to images, would Vae know to import those images as well?]]>
FedEx ground shipping option not available, Meter Number error http://forum.vaeplatform.com/discussion/122/fedex-ground-shipping-option-not-available-meter-number-error Fri, 17 Jun 2011 03:27:51 -0400 djr 122@/discussions
First of all, I have the account number, name and address details filled out and have checked all the domestic shipping options, plus international ground. The rest of the options I've left blank.

The first problem is that ground shipping doesn't appear as an option at checkout, although the other five domestic options do. There were also a few instances where I'd uncheck some of the five options and they'd continue to appear at checkout. (Ground still never appeared.)

The second problem is I keep getting the error when I try to check out:

"FedEx Shipping Module Error: We couldn't register you for a FedEx Meter Number. Double check your settings. FedEx Error #:"

This first happened when I only had domestic options checked, and adding international seemed to fix the error. After trying various combinations of domestic shipping to troubleshoot my other problem (with an international option checked the entire time), I'm now getting it every time at checkout. Could this be a problem on FedEx's end, or is there another option somewhere I need to fix?]]>
Possible to automatically discount items based on cart contents? http://forum.vaeplatform.com/discussion/115/possible-to-automatically-discount-items-based-on-cart-contents Thu, 26 May 2011 16:40:04 -0400 djr 115@/discussions